Dos fallos de Ubuntu 7.10

12 01 2008

A continuacion os muestro dos pequeños fallos de la ditribución ubuntu 7.10. Sinceramente me parecen fallos mas propios de el innombrable de microsft que de uns distribucion seria como ubuntu. En mi opinion creo que despertaron demaiadas expectativas con la version 7.10 y se le olvido cuidar todos los detalles como tradicionalmente hacen. Espero que la futura versión 8.04 no tenga errores tontos tipicos de las prisas.

Bueno ahi van los dos pequeños fallos.

UPDATE del pimer fallo: Este fallo ya esta corregido en las actualizaciones recientes de ubuntu. Si no habeis actualizado seguireis con el fallo

N0 se si os habreis dado cuenta pero en la version 7.10 de ubuntu se cargaron las consolas tty, si las que se activan con ctrl+alt+f1..6. Esto es debido a que cuando compilaron el kernel que trae esta version de ubuntu se “olvidaron” de activar ciertos modulos. Esto se soluciona muy facilmente actualizando a la versión superior del kernel, pero aun no ha sido ni publicada asi que habra que optar por otra solución, jejeje, que os muestro a continuación.

Editar el archivo /etc/modprobe.d/blacklist-framebuffer.

sudo gedit /etc/modprobe.d/blacklist-framebuffer

y comentar las lineas, recordar que para comentar solo hay que poner un # delante:

blacklist vesafb
blacklist vga16fb

Guardamos los cambios y cerramos.

A continuación tendremos que editar el archivo /etc/initramfs-tools/modules

sudo gedit /etc/initramfs-tools/modules

Y añadir lo siguiente:

fbcon
vesafb
vga16fb

Cerramos y guardamos los cambios.

UPDATE del segundo fallo: Bueno como podreis haber visto esas lineas son una tonteria, ya que hace un si el color de fondo es “x” entonces pon el color de fondo a x, ¿?¿?!!¿!¿!¿!, jejeje. Vamos que si la botella esta llena, entonces esta llena la botella.

Y por ultimo actualizamos la imagen initramfs (si es en un kernel que hemos compilado tanto framebuffer, vga, vga16 y ramfs tienen que estar habilitados en la configuración).

sudo update-initramfs -v -u -k $(uname -r)

Reiniciamos y ya esta todo arreglado.

Gracias a Magarto por la solución original a este problema que encontre en su blog, el blog de magarto.

El otro pequeño fallo es simplemente una cuestión estetica, jejeje. Existe una opcion en “Sistema>Administración>Ventana de Entrada>Local” que te permite cambiar el color de fondo de incio de sesion, es decir el fondo que aparece despues de iniciar la sesion y antes de que se cargue el escritorio. Bueno pues por defecto aparece ese marron caracteristico de ubuntu, que esta muy bien si uno tiene el tema de ubuntu en su escritorio, pero cuando cambias el tema, lo ideal es cambiar ese color de fondo y he aqui el fallo, ya que por mucho que cambies en color en esa opción no se cambia realmente.

La solucion a este estetico bug es la siguiente:

Editamos el archivo /etc/gdm/PreSession/Default

sudo gedit /etc/gdm/PreSession/Default

Buscamos las siguientes lineas de código (están por el final)

# Default value
if [ “x$BACKCOLOR” = “x” ]; then
BACKCOLOR=”#82BBDA”
fi

Cambiamos ese #82BBDA por una x. Dejandolo asi:

# Default value
if [ “x$BACKCOLOR” = “x” ]; then
BACKCOLOR=”x”
fi

Guardamos los cambios y salimos y listo la proxima vez que reiniciemos ya tendremos el color que hayamos elegido en la opcion que os comente al principio.

Simplemente no hace falta ni modificarlo, directamente borrais esas lineas.

Gracias al blog Entre tuxes y pepinos que fue donde vi la luz a este estetico problema, jejeje.

Bueno como comente al principio espero que la version 8.04 no traiga consigo errores tipicos de las prisas.

Anuncios

Acciones

Information

3 responses

23 01 2008
oscar

orale, yo visito regularmente entre tuxes y pepinos pero nunca vi ese post del bug de el color de inicio de sesión, pues en estos dias me trevi a probar gnome para probar mac4Lin y todo quedo como queria excepto ese colorcito marron.

Ahora ya se como cambiarlo man

saludos

P.D. ya tienes un lector mas en tu blog

28 01 2008
chemi

joder señor buo, estas hecho un jodido guru de linux! pena que yo siga siendo windows xDDD ahora eso si, con mi futuro juguetito tendre que cacharrear mas con linux, si quieres saber mas busca por EEE

31 12 2009
Fernando de Suecia

Hola!
Tengo problemas para instalar y desinstalar programas. Tampoco actualiza el sistema. He instalado el ububtu 8:04

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: